Holes looks good in Blender, but not in Vehicle Simulator?

Are you having problems building or configuring a vehicle addon for VSF or would you like to discuss techniques? This is where to do it!

Re: Holes looks good in Blender, but not in Vehicle Simulato

Postby Dom » Tue Oct 18, 2016 9:13 am

Saken, it looks to me that you'd have do move the geometric center (or axis origin point) because that point may be out of the field of view sometimes when rotating around the model in VSF.
Image

Formerly known as Dom ...just in case I follow this currently ongoing silly trend of changing one's screen name...
User avatar
Dom
 
Posts: 1382
Joined: Tue Jun 17, 2008 6:34 pm
Location: France

Re: Holes looks good in Blender, but not in Vehicle Simulato

Postby saken » Tue Oct 18, 2016 1:04 pm

This is what it looks like in Blender... the pivot point of the hull is at the scene origin.
WIP_October_18_2016
Kind Regards,

saken

Proud Virtual Sailor user since 2005, and Vehicle Simulator user since 2008!
User avatar
saken
 
Posts: 670
Joined: Fri Jan 30, 2009 1:36 pm
Location: Sweden

Re: Holes looks good in Blender, but not in Vehicle Simulato

Postby saken » Tue Oct 18, 2016 1:23 pm

SOLVED!!! It was the pivot point that needs to be for all objects in the scene at the scene origin :D
Kind Regards,

saken

Proud Virtual Sailor user since 2005, and Vehicle Simulator user since 2008!
User avatar
saken
 
Posts: 670
Joined: Fri Jan 30, 2009 1:36 pm
Location: Sweden

Re: Holes looks good in Blender, but not in Vehicle Simulato

Postby saken » Wed Oct 19, 2016 9:39 pm

I just found out that I would need the faces normals need to point towards where you view it from... in other words... I need double roof, walls and windows on the bridge?
Kind Regards,

saken

Proud Virtual Sailor user since 2005, and Vehicle Simulator user since 2008!
User avatar
saken
 
Posts: 670
Joined: Fri Jan 30, 2009 1:36 pm
Location: Sweden

Re: Holes looks good in Blender, but not in Vehicle Simulato

Postby Sharpy » Wed Oct 19, 2016 10:30 pm

Howdy.
You can just copy each wall etc. and flip normals.
They will be in the exact location and will not add a drag to the fps as they only show from your viewing angle.
If you use double sided walls the GPU will actually compute the texture, bump, shadows etc. even though it's not showing from your view, adding an unnecessary drag on fps.
I ususally build double walls separated by the actual thickness of the walls. 2" - 4". Each with reversed normals.

Steve
Sharpy
 
Posts: 425
Joined: Tue Jul 22, 2008 4:11 am
Location: Lahaina, Hawaii
Preferred Sim: Virtual Sailor

Re: Holes looks good in Blender, but not in Vehicle Simulato

Postby saken » Thu Oct 20, 2016 12:41 am

Thanks Steve, my model is coming along quite nicely :)
Kind Regards,

saken

Proud Virtual Sailor user since 2005, and Vehicle Simulator user since 2008!
User avatar
saken
 
Posts: 670
Joined: Fri Jan 30, 2009 1:36 pm
Location: Sweden

Re: Holes looks good in Blender, but not in Vehicle Simulato

Postby saken » Thu Oct 20, 2016 6:10 pm

Found a new problem in Vehicle Simulator... does anybody know how to get rid of this line in the middle of this window?
Attachments
Window.JPG
Kind Regards,

saken

Proud Virtual Sailor user since 2005, and Vehicle Simulator user since 2008!
User avatar
saken
 
Posts: 670
Joined: Fri Jan 30, 2009 1:36 pm
Location: Sweden

Re: Holes looks good in Blender, but not in Vehicle Simulato

Postby Sharpy » Thu Oct 20, 2016 9:51 pm

Howdy.
In AC3d you would snap together and weld vertices. Not sure the terminology is the same in Blender.
This makes for a perfectly somooth transition.

Steve
Sharpy
 
Posts: 425
Joined: Tue Jul 22, 2008 4:11 am
Location: Lahaina, Hawaii
Preferred Sim: Virtual Sailor

Re: Holes looks good in Blender, but not in Vehicle Simulato

Postby saken » Thu Oct 20, 2016 11:19 pm

I also forgot to mention that this was across a mirror modifier. It's across the middle of the ship. So I don't know if that applies there?
Kind Regards,

saken

Proud Virtual Sailor user since 2005, and Vehicle Simulator user since 2008!
User avatar
saken
 
Posts: 670
Joined: Fri Jan 30, 2009 1:36 pm
Location: Sweden

Re: Holes looks good in Blender, but not in Vehicle Simulato

Postby saken » Fri Oct 21, 2016 12:51 am

This is basically my problem, I want to mirror a seam along the X axis.
https://1drv.ms/i/s!Aor67FEekLdyg94PjycL09gOehnS2A
Kind Regards,

saken

Proud Virtual Sailor user since 2005, and Vehicle Simulator user since 2008!
User avatar
saken
 
Posts: 670
Joined: Fri Jan 30, 2009 1:36 pm
Location: Sweden

PreviousNext

Return to VSF Vehicle Development Support

Who is online

Users browsing this forum: No registered users and 1 guest